How to install Linux Kernel 4.3.0 on LinuxMint 17.x?

Recently I got a spanking brand new IntelNuc device for my lab experimentation. This little, inexpensive jewel unfortunately didn't cope well with my favorite 64 bit LinuxMint 17.2 Xfce OS. As the version 3.16.0-38 kernel boot-up, everything was fine except for the video output which was nowhere to be found. After briefly scratching my hair, I came to the conclusion that I should give a try to a more recent version of the Linux kernel, maybe something in the 4.3 generation.

After a bit of research on the internet I found out that Ubuntu, the upstream of LinuxMint, already had 4.3.0 in its repository.

In order to upgrade LinuxMint 17.2's kernel from version 3.16.0 to 4.3.0 download one or the other set of files according to your version of Mint.

If you have a 32 bit version of LinuxMint run the following commands:

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-headers-4.3.0-040300_4.3.0-040300.201511020949_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-headers-4.3.0-040300-generic_4.3.0-040300.201511020949_i386.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-image-4.3.0-040300-generic_4.3.0-040300.201511020949_i386.deb
sudo dpkg -i linux-headers-4.3.0*.deb linux-image-4.3.0*.deb
sudo update-grub
sudo reboot

For 64 bit LinuxMint, use the following lines:

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-headers-4.3.0-040300_4.3.0-040300.201511020949_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-headers-4.3.0-040300-generic_4.3.0-040300.201511020949_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-image-4.3.0-040300-generic_4.3.0-040300.201511020949_amd64.deb
sudo dpkg -i linux-headers-4.3.0*.deb linux-image-4.3.0*.deb
sudo update-grub
sudo reboot

After running the above script (including reboot) you may need to run "Grub Customizer" if the boot menu still doesn't show the new kernel version.

You may also have to uninstall and reinstall VirtualBox if it was already installed prior to upgrading the Linux kernel.

This upgrade procedure was tested multiple times with different 17.x versions of Mint both in 32 and 64 bit configurations (albeit only with Xfce). The kernel version 4.3.0 works well and without missing a beat!

Now, as mentioned earlier, you may need to uninstall and reinstall those programs that hook up closely with the kernel, like VirtualBox. But, once done they all work nicely with 17.x/4.3.0.

In addition to the above source you can also download the kernel bundles from our site:
LK-U-LM_32b_4.3.0-040300.7z MD5: 3fb2c71c97442cc4e049d0ed6794cb71
LK-U-LM_64b_4.3.0-040300.7z MD5: 5f36ea4df84e6dff63878ea72a17c63b

(© cilicia.us - originally published on January 3, 2016)

cilicia.us & The Cilician Gazette © Copyright 1991-2018 - All rights reserved